You Can't Chop Off Win7 Pro's Head and Escape the Wrath


#1

I got a nice i3 from a friend the other day. It was loaded with win7 Pro. I was almost done loading my goodies into it and I had this brilliant idea! Why not partition it so my files are better protected? (That was a real “Like Duh” moment) Uggg. I sliced right through the windows 7P OS with partition magic. It locked up about 2/3 of the way through. Bummer because 7 Pro isn’t that bad. However, I wanted the laptop to try Ubuntu 14.05 anyway, but I was going to pull the win 7 drive and go with a smaller one for a test run. I went on line and procured an ISO of 14.05. I loaded 14.05 because someone said it was a lot better than 16.05

OK. Time to simply load 14.05 as windows could not recover from the headman’s axe. Yes, I know I could have load it beside windows, but I did that on another machine and it said I would have to partition the drive to install it and I did not want to move all of my files for that.

When I went on line for the updated packages I was asked if I wanted to “upgrade” to a “newer” version. I’m only getting 5 meg Internet service but it appeared to be a good idea at the time.

I hit YES, then I remembered the blog. Oh well.

It took around 7 hours to load the 2gigs of packets and install them. I went to bed after several hours as it was 4 AM by then. I thought I would wake up go downstairs and find my machine all loaded and ready. NOPE. It pulled a microsuck on me with an “Are you sure you want to replace your newer file with this older file?” NO. Then I went through hours more of loading and installing.

Finally it was all loaded up and running. No DVD movie player so I sent Ubuntu to go fetch the files needed to remedy the problem. One file could not be found after a gazillion searches… so that nixed that. Next I tried VLC but couldn’t get that because I didn’t understand the loading gobbeldy gook and decided not to pull another brilliant move on THIS OS as I did win 7.

OK I’m stuck now. No DVD movies for me. I would assume that the missing file was pulled to prevent installing the program in this 16 version.

But on the brighter side, no DVD movies or not, I LOVE THIS OS. No problems figuring out the brain dead poser stuff out at all.

Years ago it wasn’t very friendly to poser nerds, but this OS is friendly. I may even slice through some more machines OS as a symbolic protest to windows and install Ubuntu on several more machines. But no way will I load 14 and upgrade to 16 again. I’ll just go for 16 at the start.

Nerds do that all the time, don’t they? I think that they like it.


#2

Well I’m biased since I work for the company that makes Ubuntu, but 16.04 has had lots of updates, so I recommend that. 17.04 will be out in April.

If you didn’t select install restricted extras at the beginning you can still do that after…

Hit the Ubuntu Icon in the top left, search for Software & Updates and open it. In the Ubuntu Software tab, select Software Restricted by Copyright bla bla… Close it and let it do its thing.

Open Up a terminal (Ctrl + Alt + T) and type:

“sudo apt-get update”
“sudo apt-get install ubuntu-restricted-extras libdvdcss libdvdread4 libdvdnav4 vlc”

You should be able to play DVDs now.

BTW you can also install “wine” which lets you install windows programs to run under linux (to various degrees of success depending on the program).

My main work machine which is the latest Ubuntu (A pre-release version of 17.04 currently) is also now my DAW. I use a lowlatency linux kernel and with the Axe-Fx II as a sound card I get 64 samples of latency.
I use the windows version of Reaper which works fine for me under Ubuntu (though you need wine ASIO to make it compelling to use under linux)
Heck I can compile source code while playing piano (The piano simulation software is running on my machine) and I don’t get artifacts. I couldn’t do that with Windows…

I just wished more VSTs and plugins were made compatible with at least Wine (the


#3

Thanks bro!

I think I tried that once already, according to a Linux board post but for some reason it didn’t take. I will try it again.

I also tried to load VLC and it gave me some bla bla bla…

I just read about “wine” about two hours ago while I was searching to find a player.

I also copied and pasted some links for videos in Ububtu and put them on a USB stick. Windows wouldn’t open them so I went to some place on line where they translated them.

Then I thought since both systems use Firefox I should simply mail them to myself to a windows machine and they should translate themselves. Worked like a charm. No offense, but why do programmers make things so difficult? There should ne no reason that ubuntu wouldn’t translate outgoing text to a win format since the majority of computer owners who Linux based people correspond with use them. It’s crap to have to mail your text to yourself on another machine as opposed to walking across the room because you had to mail it to yourself.

I am going right not to faithfully obey your instructions and try to get that player running. Regardless outside of the comparability of a few things I really do prefer ubuntu hands down to win 7 and up. At least you have some control over your own machine. Thanks again for the help. :slight_smile: I copied your post and will have it in front of me when I attempt again.


#4

That’s strange it shouldn’t be an issue. Do you remember which program you used to save the text?

In Linux/Unix systems we don’t really use extensions. I know on Windows systems, I believe the default is not to show the extension to the user. For example a text file should be named “example.txt”. Windows File Explorer depending on its configuration may not show the extension (.txt) but it’s necessary so you can open files.

So if you save a file on Ubuntu, just add .txt at the end. Why is that not done by default? Because in Unix/Linux world we generally don’t use extensions…this was inherited from the design of Unix which predates Windows.

Just post here, if you have any more questions, I’ll help you out…

I find it interesting to see the usage patterns from a new user’s point of view. A lot of times that type of user feedback is not seen - usually one deals with other nerds :grin:


#5

The text files are in an .odt extension. I see where a lot of windows users have a problem with this. I googled I can’t read my ubuntu notes on windows and a ton of links came up where a lot of users had the same problem. They suggest converters. I downloaded one and it looked like a programmers sheet. with all manner of strange symbols. “Libreoffice writer” is the only program for text that was on the taskbar when Ubuntu was finished loading. Reguardless I do not like it as it came with tos of stuff I’ll never use. I wanted a simple program like"note pad" to paste in urls so I could use them when I was at other machines. I did finally get Libreoffice to look like I wanted it to look, but unlike windows I could not find an option to send text to the desktop where it is handy for such things. After squeezing it to a narrow window I can live with it.

I remember the problem I had after I was reminded of it.

When it came to the password it wouldn’t let me type anything in. Not that it matters since I lost the Badstrat password while updating at 4AM and do not know how to retrieve it. I was a bit under duress after losing win7Pro and having to contend with typing my password for permission to load every two minutes. But the pass I use for that is not the Badstrat pass anyway evidently that got lost in the shuffle. I probably didn’t write it down while I was preoccupied with all the loading stuff. But this is what I get when I do as you said. I have no idea of what this “Badstrat@badstrat” is at all. I might understand if it simply said badstrat but it wouldn’t matter. I just screwed up at the start. For me it was Nice try but no reward.

badstrat@badstrat-TM4750:~$ sudo apt-get update
[sudo] password for badstrat:


#6

Ahh right you used LibreOffice Writer. That’s the equivalent of Microsoft Word. If you want to save into the format Word uses, click Save As… In the Save dialog box click on the box in the right bottom corner that says “All Formats”, then choose Microsoft Word 97-2003(.doc).

But if you just want to save a simple text file, you can use GEdit. Click on the Ubuntu icon in the top left corner, and search for text editor. When saving, select in the box that says Line Ending, Choose windows. And make sure you save the file with a .txt extension.

I remember the problem I had after I was reminded of it.

When it came to the password it wouldn’t let me type anything in.

Oh yeah it can look that way. The reasons for not displaying asterisks is the paranoid nature of us linux nerds :slight_smile: Displaying asterisks or something would tell the length of the password to some onlooker… :grin:
Nevertheless it is taking your password in.

Not that it matters since I lost the Badstrat password while updating at 4AM and do not know how to retrieve it. I was a bit under duress after losing win7Pro and having to contend with typing my password for permission to load every two minutes. But the pass I use for that is not the Badstrat pass anyway evidently that got lost in the shuffle. I probably didn't write it down while I was preoccupied with all the loading stuff. But this is what I get when I do as you said. I have no idea of what this "Badstrat@badstrat" is at all. I might understand if it simply said badstrat but it wouldn't matter. I just screwed up at the start. For me it was Nice try but no reward.

badstrat@badstrat-TM4750:~$ sudo apt-get update
[sudo] password for badstrat:

Umm, sounds like maybe you don’t have a password set then, otherwise how were you able to login into the desktop?
Try this, open a terminal (Ctrl + Alt + T ) and type “passwd”. It will ask you for your current password. If it doesn’t then you don’t have a password and can now set one. If it does ask for one, just try pressing ENTER to see if you have a blank password maybe…


#7

I loged in at the very beginning …evidently with something I do not remember. I tried what you said and this came up

badstrat@badstrat-TM4750:~$ password
No command ‘password’ found, did you mean:
Command ‘assword’ from package ‘assword’ (universe)
password: command not found

I am going to do what you showed me to change the word doc extension. Thanks.

I am slightly dislexic so that may have been a password problem from the beginning. I tried every pass I had incase I used one of them always the same response.

badstrat@badstrat-TM4750:~$ SlackerG
SlackerG: command not found


#8

It should be “passwd” not the whole word password i.e. take off the “o” and the “r”


#9

I tried the word processor change. That worked. Any way to make .rtf or .doc the default or do you have to go through the whole process every time?

Here is what I get per your instruction on password change. Evidently I typed something into it.

badstrat@badstrat-TM4750:~$ passwd
Changing password for badstrat.
(current) UNIX password:

I get into the system because I chose not to have to enter a password each time I booted up. The code I use when downloading files evidently is different than the Badstrat password. I tried the password that I use for downloading packages but that doesn’t work here.

Here is what I get when I use the package cpass: (I put * in place of actual letters and numbers

badstrat@badstrat-TM4750:~$ ********
********: command not found
badstrat@badstrat-TM4750:~$

I’m going to try another one as it shows 4 **** when asking


#10

Yeah if you go to the Top menu, Tools->Options->Load/Save->General, at the bottom there’s a “Always save as”.


#11

Thanks.

Now I’ll get that problem solved. Sometimes this reminds me of the good old DOS days that I could hardly wait to get away from. Now when I try to go get “wine” I get the password again even for that and get stopped in my tracks

Is reloading the only way to solve the password problem? That would be a pain but April is a ways away so I would like to get familiar with this OS regardless.

In the past I became frustrated and just said the hell with it and loaded win, but this time I want to hold out and pry myself away from windows. I like what the nerd community has been doing for the last 10+ years on this O.S. It has come a long way through the years.

I’m off to customize my wps.


#12

Yeah you can reset the password without knowing it, but it’s a bit involved - here goes:

Reboot your computer then hold the Shift key. You should eventually see something like this:

Choose Advanced options for Ubuntu, then select the entry that says Ubuntu, with Linux bla bla (recovery mode) <— You want recovery mode
Hit Enter, you should get a screen similar to this:

Now scroll down to select the “root Drop to root shell prompt” And press Enter until you get a command line prompt:

root@badstrat-TM4750:~: or something like that

Then type: “passwd badstrat” and enter a new password. It’ll ask to confirm the password.
Then type: “reboot” and you are done!


#13

YOU made my day kind sir.

I was there before once (second screen) but I did not know what to do after I got there. Now I will copy and save your instructions and try it.

I tried to use my Ububtu machine for movies last night. I plugged in a HDMI to the TV and I had two different screens. That was kinda cool, but I needed to see the movie I was watching on the small screen. After a bit of fumbling I managed to get the small screen off and the movie on the TV. No sound. In my system I run all sound through the TV so I do not need a switcher for audio. It handles two DVD players a VCR and the computer. You like user suggestions? Sony does a couple of things that are cool.

When you plug into the HDMI and have the TV to that HDMI input, the computer screen shuts off and the TV is used as a monitor, but it also has the sound as well as the picture. If you leave the HDMI input the computer screen turns on again at the proper resolution. You can watch a program on TV and one on the laptop, not that I would. It would nice nice if Ubuntu could do that with a simple command, even though Sony does it automatically whenever you plug in the HDMI. Very user friendly for slow people.

With all your help I think that I can get through this transition from Win to Ubuntu. I can’t express how much I appreciate your help. :slight_smile:

I’m going to copy this page for future reference in case I do something stupid in the future.

They should route the audio through the HDMI cable as well as the sound card output.


#14

You solved it.

The first time I went to change the password I tried to think of what I should use that I could remember. While I was considering it I got a time out. Kinda like a quiz show isn’t it? All it needed was a gong. Next time, knowing there is a time limit I had it all written down and it went smoothly.

Now I can search for DVD packages. Thank you again and again. I’m a happy camper again. And I won’t have any more password problems in the future either.

Once I install an audio switch box I can watch Internet and possibly DVD movies with this system. If that is the case and it works out I’ll put it on another machine for upstairs. :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile:


#15

Glad you got it figured out.

For HDMI to output sound, you should be able to click on the speaker icon in the top right corner, Select sound settings, and then select the device that contains hdmi in the name. IF there are none… then probably that h/w is not currently supported by the kernel.


#16

Well, I didn’t figure it out, you did. :slight_smile:

Unfortunately for me this version does not have the audio option. However, it is so much faster and it blocks all the ads on the movies so I should make an A/B switch for the system audio… at least until I can lay my hands on 17. After using Ubuntu as a browser win seems unbelievably sluggish.

It would be nice if there was an Internet version such as the Chrome OS where everything is stripped out except the essentials. I hear that Chrome boots in around 2 seconds and is ready for browsing.

Neither does this version give you the “always save as” when using the word program. I can live with that. So all I need to do is import a good DVD player for movies and this will be used as much or more than any of my windows machines. Now that you solved the password problem for me I should be able to do that.


#17

Yeah I have a couple of Chromebooks I got for the kids, but I removed it and installed ubuntu since I’m teaching them programming and just so much easier to do that with a proper linux distribution :slight_smile:


#18

Are they older Celeron Chromebook or i3 Chromebook? I see that I can purchase an older non 4K Celeron Chromebook for about $129-$159. Is it difficult to replace the Chrome OS? What version OS did you install? I would like to do that if it isn’t a monumental task. I have read that the Firefox browser can be grafted into the Asus Chromebook.

Even though the password has been changed and the OS said it was changed it still won’t accept it. I have gone through the process a couple of times using the same password. I may be getting another laptop to experiment on. If that happens I will pay more attention from the beginning and see if it works.

I took the time to download the 16 ISO, but when I went to make a bootable DVD it did not have the wubi.exe file in it when I made a DVD with ISO Buster for some reason. Yet it worked fine for the 14 ISO download. Can I take the wubi from 14 and put it in 16 and load the OS on a formatted Hdd? It appears that everything else if there.

Obviously I have little idea of what I am doing in Ubuntu.


#19

One of them was a HP 14-q029wm Chromebook PC with Intel Celeron 2955U Processor
The other was an Acer CB3-111-C8UB 11.6" that I got for $100.

They are not terribly fast but they are useful for what I need them for.

Replacing ChromeOS is fairly involved. You have to open the laptops, remove the write-protect screw, install new BIOS firmware (https://mrchromebox.tech/#fwscript), get a USB key with Ubuntu ISO on it… and potentially fix any compatibility issues (by compiling a custom linux kernel or modules).

I don’t really use windows so no idea on Wubi.

I usually just make USB keys with the ISO files. I believe you can use Rufus for that in Windows, but again I’ve never used it myself.


#20

OK.

I guess that the switch from Chrome OS to Linux just isn’t for anyone. :slight_smile: All the articles say that Chrome boots in seconds.

Well big deal. So does my Ubutu machine… in about 130 of them.

I believe that wubi.exe is the launcher or loader (I have no idea of the terminology used here) that begins to load Ubuntu on a formatted hard drive when the machine sees it in the DVD drive.

I will try to slide that into a DVD along with Ubuntu the other 16 files and see if it loads the OS.

I got dizzy just reading the article in your link.